No device data in GUI


  • Deutsche Telekom IoT

    As some of you have already experienced, we have problems displaying the latest device payload in the project GUI.

    Our colleagues have been investigating for some time and unfortunately we haven’t found a solution yet.

    In the meantime:

    This doesn’t mean you can’t get your device data. When you register the callback URL of your application (server), your device data will still be forwarded to the destination you specified. 🙂

    If you don’t have an application server and only use our GUI to see if your messages are coming in properly, use beeceptor for the time being.

    As soon as we have an update, we’ll let you know here.


  • Deutsche Telekom IoT

    To give a good explanation of what exactly is going on, I also have to give some context.

    Each project is connected to a tenant on our Service Capability Server.

    After registering an IMEI in our GUI you usually switch your device on and it will send its first uplink message. The Service Capability Servers considers the first uplink message as a registration message. So on top of the payload it will add some additional information: to which tenant the sending device belongs.

    This registration message is very important to our GUI. It tells our GUI that it belongs to your tenant. This way, our GUI will know that we can show the payload in your project (since you are the owner of the tenant).

    So what’s the problem?

    Our Service Capability Server has a separate queue for registration messages. And this queue is overloaded. The registration messages are arriving with a delay of hours/days. Our team is still trying to find out why it is overloaded and how we can fix it.

    The good thing: it is a separate queue. For non-registration messages (your regular uplink messages) there is no delay. If you configure the callback URL of your own application server/IoT platform, you will receive your device data right away.

    Unlike our GUI, your application doesn’t care about this registration message. 🙂

    Hope to have more news tomorrow in the afternoon.



  • Any updates? Tried yesterday still no data in the portal.


  • Deutsche Telekom IoT

    Unfortunately not yet. Still working on a fix.


Log in to reply